vue cli4 使用iVIew 定制主题出现的错误

按照官方的教程,在main文件中引入自定义的less文件,在这个前提下,我们需要less语言解析

yarn add less less-loader --dev

安装完我们main引入自定义的less文件,结果启动的时候出现错误:

Inline JavaScript is not enabled .bezierEasingMixin();

这个错误一般是因为新版本less带来的,你可以换旧版,比如5.0的版本

我们在项目根目录找到vue.config.js文件,没有你就创建这个文件

填入以下:

module.exports = {
    css: {
        loaderOptions: {
            less: {
                javascriptEnabled: true,
            }
        }
    },
}

然后保存,启用,如果此时你还是报错,并且提示:

Module build failed (from ./node_modules/less-loader/dist/cjs.js):
ValidationError: Invalid options object. Less Loader has been initialized using an options object that does not match the API schema.
 - options has an unknown property 'javascriptEnabled'. These properties are valid:
   object { lessOptions?, prependData?, appendData?, sourceMap?, implementation? }

说明你的版本是最新版的,配置要改一下,再次打开vue.config.js,改为:

module.exports = {
  css: {
    loaderOptions: {
      less: {
        lessOptions: {
          javascriptEnabled: true
        }
      }
    }
  },
}

这样就行了。

0
  • 本文分类:vue 项目实战
  • 本文标签:vueiview定制主题
  • 流行热度:已超过 159 人围观了本文
  • 发布日期:2020年08月17日 - 1时12分58秒
  • 版权申明:本文系作者@木灵鱼儿原创发布在木灵鱼儿站点。未经许可,禁止转载。

相关文章

微信收款码
微信收款码